Unrecognized token 3C in formula

Topics: Developer Forum, User Forum
Jan 18, 2010 at 3:53 PM


I ve download the latest version of PHPExcel, but i have some issues to open somes PHP5 files, with the message "Unrecognized token 3C in formula" or "Unrecognized token 39 in formula"


Could you help me ?

Here it is the workbook : http://ww2.nodevo.com/files/GdB_Delai_rdv_imagerie_v8 plein.xls


Thanks you a lot

Jan 18, 2010 at 4:44 PM

Looking at your worksheet, I see formulae containing functions like ALEA.ENTRE.BORNES()

I don't know every Excel function in every language, but I've never seen this before? Is this the French name for a standard Excel function? the French name for a function in Excel analysis toolkit? Or a user-defined function?

Jan 19, 2010 at 7:13 AM
Edited Jan 19, 2010 at 7:14 AM

Yeah, I also get the error about token 39 when I try to load that xls file.

MarkBaker, I think you are right about ALEA.ENTRE.BORNES() causing the problem. According to "OpenOffice's Documentation of the Microsoft Excel File Format" section 3.9.14 token 0x39 may have to do with add-in functions.

Hope we can fix this somehow. Creating work item:


Jan 19, 2010 at 8:13 AM

ALEA.ENTRE.BORNES() is the RANDBETWEEN() function from the Analysis Toolkit. I Found it in the MS Notes Equivalences FR/US de l'utilitaire d'analyse (ATP)

There's already a work item for analysis toolpack functions in the Excel5 writer http://phpexcel.codeplex.com/WorkItem/View.aspx?WorkItemId=10692


Jul 26, 2012 at 10:48 AM


I'm also getting "Unrecognized token 3C in formula",  I'm using phpexcel version 1.7.7, PHP 5.3.6.

The workbook is here: Unrecognized token 3C in formula.xls

I suspect it's maybe a function from the Analysis Toolkit or a user defined function but I'm unable to locate the formula.

I've also tried reading a sheet that contains no formulae and a single text cell and limit the read to this sheet with:

    $objReader = PHPExcel_IOFactory::createReaderForFile($this->file);
    $sheetname = "Sheet1";

but still get the token 3C error.

Any help would be greatly appreciated...