Column AAA Error

Topics: User Forum
Apr 29, 2008 at 4:35 PM
Hi, my first time discussing with the group.

I have developed a web-based application that uses PHPExcel and sometimes gets an error from what I believed is cased by column "AAA." Below is a copy of the specific error I get:

Fatal error: Uncaught exception 'Exception' with message 'Column string index can not be longer than 2 characters.' in C:\Documents and Settings\xxxxxxxx\My Documents\xampp\kdapi\new\php\phpexcel\Classes\PHPExcel\Cell.php:486 Stack trace: #0 C:\Documents and Settings\xxxxxxxx\My Documents\xampp\kdapi\new\php\phpexcel\Classes\PHPExcel\Writer\Excel2007\Worksheet.php(288): PHPExcelCell::columnIndexFromString('AAA') #1 C:\Documents and Settings\xxxxxxxx\My Documents\xampp\kdapi\new\php\phpexcel\Classes\PHPExcel\Writer\Excel2007\Worksheet.php(113): PHPExcelWriterExcel2007Worksheet->writeCols(Object(PHPExcelSharedXMLWriter), Object(PHPExcelWorksheet)) #2 C:\Documents and Settings\xxxxxxxx\My Documents\xampp\kdapi\new\php\phpexcel\Classes\PHPExcel\Writer\Excel2007.php(298): PHPExcelWriterExcel2007Worksheet->writeWorksheet(Object(PHPExcelWorksheet), Array) #3 C:\Documents and Settings\xxxxxxxx\My Documents\xampp\kdapi\new\php\processing.php(2507): PHPExcelWriterExcel2007->save('C:\Documents an...') #4 C:\Documents a in C:\Documents and Settings\xxxxxxxx\My Documents\xampp\kdapi\new\php\phpexcel\Classes\PHPExcel\Cell.php on line 486

This is quite a mouthful but using my common sense, it appears that column is only from A to ZZ, once at AAA the error appears. And this error does not appear when I generate smaller spreadsheets.

Is this a:
  • Configuration Issue
  • Programming Issue
  • Common PHPExcel bug
  • Problem with my PHPExcel version. I checked it and it is 1.5.5.

Just to help out, here are my system details:

  • Running on a Windows XP box with XAMPP installed.

If ever this is a problem with my PHPExcel version, what any other drastic problems appeared from upgrading from 1.5.5 to the current 1.6.1?

Thanks to everyone in advance.
Coordinator
Apr 30, 2008 at 2:07 PM
It's actually a feature! :-)

We blocked cell ranges > ZZ for the reason of compatibility with older Excel versions (using the compatibility pack). This way, no data is lost when the file is converted.
Apr 30, 2008 at 4:35 PM
Thanks maartenba... now assuming I want to stay with MS Excel 2007 and does not want to be compatible with older versions, is there any setting I can change to make it go beyond ZZ?
May 1, 2008 at 2:33 AM

BenjArriola wrote:
Thanks maartenba... now assuming I want to stay with MS Excel 2007 and does not want to be compatible with older versions, is there any setting I can change to make it go beyond ZZ?


If it is not really possible, then maybe my next best solution is create a new sheet when ZZ is reached.
Coordinator
May 2, 2008 at 10:00 AM
I will make this feature optional in the next version.
Coordinator
May 2, 2008 at 10:01 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.