pearplex/PHPExcel requires PHP extension "zip" (version >= 1.8.0), installed version is 1.4.0

Topics: Developer Forum
Mar 29, 2011 at 8:57 PM

I am having trouble installing PHPExcel and receive the following error when running sudo pear install pearplex/PHPExcel

pearplex/PHPExcel requires PHP extension "zip" (version >= 1.8.0), installed version is 1.4.0

I am running Ubuntu 8.04 PHP Version 5.2.4-2ubuntu5.14

zip from pecl list: 

zip      1.10.2  stable

from phpinfo.php :

Zip enabledExtension Version $Id: php_zip.c,v 1.1.2.38 2007/08/06 22:02:32 bjori Exp $Zip version 2.0.0Libzip version 0.7.1

 

I have tried downgrading the pecl zip package to 1.8.0 and still receive the same error.  Can anyhone help me get this installed? Thanks