PHP 4 compatibility

Topics: Developer Forum
Sep 4, 2007 at 11:24 PM
Hi,

Before I start attempting this, are there any features of this set of classes which would not be able to be implemented in PHP 4?
We would love to upgrade to PHP 5 to be able to use these classes, but unfortunately this is just not feasible for us.

Regards,
Peter
Coordinator
Sep 5, 2007 at 8:01 AM
Hello Peter,

The ability of not being able to have a PHP5 makes me think you are using shared hosting in Belgium ;-) I've had the same problem too...

PHPExcel is 100% PHP5 code, so no PHP4 support I'm affraid...

Regards,
Maarten
Sep 5, 2007 at 8:59 PM
Hi,
I've got a similar question, my webhost currently runs PHP-5.0.2 and when I try to run any of the test files the scripts stops running after including the class files.
I know the requirements say PHP version 5.2 but I was still wondering if there is anything that can be done?

//husker475
Sep 5, 2007 at 9:00 PM
Hi Maarten,

Shared hosting in New Zealand is much the same, I'm afraid :)
My question is - is there anything that is done in PHP 5 that I can NOT (with a little/lot of work and work-arounds) do in PHP 4?
I don't mind that PHPExcel has no support for PHP 4 at the moment.

Regards,
Peter
Coordinator
Sep 6, 2007 at 7:10 AM
Basically you have to find alternatives for XML reading/writing and an alternative for php_zip's ZipArchive class.
And good testing of course :-)